mt-check.cgiはシステムの構成を確認し、Movable Typeを実行するために必要なコンポーネントがそろっていることを確認するためのスクリプトです。

システム情報

確認中: 必須モジュール

CGI::Cookie

サーバーに CGI::Cookie がインストールされています(バージョン 1.20)。

File::Spec (version >= 0.8)

サーバーに File::Spec がインストールされています(バージョン 3.40)。

Image::Size

サーバーに Image::Size がインストールされています(バージョン 2.93)。

CGI

サーバーに CGI がインストールされています(バージョン 2.80)。

確認中: データストレージモジュール

これらのモジュールは、Movable Type がデータを保存するために必要なモジュールです。DBIと、1つ以上のデータベース用のモジュールをインストールする必要があります。

DBI (version >= 1.21)

サーバーに DBI がインストールされています(バージョン 1.627)。

DBD::mysql

サーバーに DBD::mysql がインストールされています(バージョン 4.023)。

DBD::SQLite

サーバーに DBD::SQLite がインストールされています(バージョン 1.39)。

DBD::Pg (version >= 1.32)

DBD::Pgがインストールされていないか、インストールされているバージョンが古い、または DBD::Pgの動作に必要な他のモジュールが見つかりません。 PostgreSQLデータベースを使うにはDBD::Pgのデータベースドライバが必要です。 DBD::Pgのインストールはインストールマニュアルに沿って行ってください。

DBD::SQLite2

サーバーに DBD::SQLite2か、DBD::SQLite2の動作に必要な他のモジュールがインストールされていません。 SQLite (v2) データベースを使うにはDBD::SQLite2のデータベースドライバが必要です。 DBD::SQLite2のインストールはインストールマニュアルに沿って行ってください。

確認中: オプションモジュール

これらのモジュールのインストールは任意です。お使いのサーバーにこれらのモジュールがインストールされていない場合でも、Movable Type の基本機能は動作します。これらのモジュールの機能が必要となった場合にはインストールを行ってください。

Scalar::Util

サーバーに Scalar::Util がインストールされています(バージョン 1.27)。

Crypt::DSA

サーバーに Crypt::DSAか、Crypt::DSAの動作に必要な他のモジュールがインストールされていません。 コメント投稿時のサインインが高速になります。 Crypt::DSAのインストールはインストールマニュアルに沿って行ってください。

XML::SAX

サーバーに XML::SAX がインストールされています(バージョン 0.96)。

IPC::Run

サーバーに IPC::Runか、IPC::Runの動作に必要な他のモジュールがインストールされていません。 MTのイメージドライバとしてNetPBMを利用する場合に必要となります。 IPC::Runのインストールはインストールマニュアルに沿って行ってください。

Archive::Zip

サーバーに Archive::Zipか、Archive::Zipの動作に必要な他のモジュールがインストールされていません。 バックアップと復元で圧縮の機能を利用する場合に必要となります。 Archive::Zipのインストールはインストールマニュアルに沿って行ってください。

Storable

サーバーに Storable がインストールされています(バージョン 2.45)。

SOAP::Lite (version >= 0.5)

サーバーに SOAP::Lite がインストールされています(バージョン 0.710.08)。

List::Util

サーバーに List::Util がインストールされています(バージョン 1.27)。

HTML::Entities

サーバーに HTML::Entities がインストールされています(バージョン 3.69)。

Digest::MD5

サーバーに Digest::MD5 がインストールされています(バージョン 2.52)。

Text::Balanced

サーバーに Text::Balanced がインストールされています(バージョン 2.02)。

Crypt::SSLeay

サーバーに Crypt::SSLeay がインストールされています(バージョン 0.64)。

GD

サーバーに GDか、GDの動作に必要な他のモジュールがインストールされていません。 アップロードした画像のサムネイルを作成する場合に必要となります。 GDのインストールはインストールマニュアルに沿って行ってください。

Archive::Tar

サーバーに Archive::Tar がインストールされています(バージョン 1.92)。

Safe

サーバーに Safe がインストールされています(バージョン 2.31_01)。

IO::Uncompress::Gunzip

サーバーに IO::Uncompress::Gunzip がインストールされています(バージョン 2.061)。

Digest::SHA1

サーバーに Digest::SHA1か、Digest::SHA1の動作に必要な他のモジュールがインストールされていません。 VoxとLiveJournal、あるいはOpenIDでコメント投稿者を認証するために必要になります。 Digest::SHA1のインストールはインストールマニュアルに沿って行ってください。

IO::Compress::Gzip

サーバーに IO::Compress::Gzip がインストールされています(バージョン 2.061)。

XML::Atom

サーバーに XML::Atom がインストールされています(バージョン 0.25)。

Image::Magick

サーバーに Image::Magick がインストールされています(バージョン 6.78)。

LWP::UserAgent

サーバーに LWP::UserAgent がインストールされています(バージョン 2.001)。

MIME::Base64

サーバーに MIME::Base64 がインストールされています(バージョン 3.13)。

Mail::Sendmail

サーバーに Mail::Sendmailか、Mail::Sendmailの動作に必要な他のモジュールがインストールされていません。 SMTPサーバーを経由してメールを送信する場合に必要になります。 Mail::Sendmailのインストールはインストールマニュアルに沿って行ってください。

HTML::Parser

サーバーに HTML::Parser がインストールされています(バージョン 3.71)。

File::Temp

サーバーに File::Temp がインストールされています(バージョン 0.12)。

システムのチェックを完了しました。

Movable Typeを利用できます。 お使いのサーバーには、Movable Type の動作に必要なすべてのモジュールがインストールされています。モジュールを追加インストール作業は必要はありません。マニュアルに従い、インストールを続けてください。